Daniel Reetz, the founder of the DIY Book Scanner community, has recently started making videos of prototyping and shop tips. If you are tinkering with a book scanner (or any other project) in your home shop, these tips will come in handy. https://www.youtube.com/channel/UCn0gq8 ... g_8K1nfInQ

Spreads on Linux Mint: First Impressions

General discussion about software packages and releases, new software you've found, and threads by programmers and script writers.
Cypris2010
Posts: 11
Joined: 06 Feb 2014, 10:58
Number of books owned: 0
Country: Germany

Re: Spreads on Linux Mint: First Impressions

Post by Cypris2010 » 06 Feb 2014, 12:08

Now I Have the folowing error:

Code: Select all

(.spreads)fabian@fabian-virtual-machine:~/spreads$ spread configure
spreads encountered an error:
Traceback (most recent call last):
  File "/home/fabian/spreads/spread", line 39, in <module>
    cli.main()
  File "/home/fabian/spreads/spreads/cli.py", line 410, in main
    setup_plugin_config(config)
  File "/home/fabian/spreads/spreads/plugin.py", line 336, in setup_plugin_config
    pluginmanager = get_pluginmanager(config)
  File "/home/fabian/spreads/spreads/plugin.py", line 310, in get_pluginmanager
    name_order=True)
  File "/home/fabian/.spreads/local/lib/python2.7/site-packages/stevedore/named.py", line 55, in __init__
    verify_requirements)
TypeError: _load_plugins() takes exactly 4 arguments (5 given)
Has sombody any idea what this is?

User avatar
jbaiter
Posts: 98
Joined: 17 Jun 2013, 16:42
E-book readers owned: 2
Number of books owned: 0
Country: Germany
Location: Munich, Germany
Contact:

Re: Spreads on Linux Mint: First Impressions

Post by jbaiter » 06 Feb 2014, 13:44

It's a known issue with a newer version of the 'stevedore' package.
Matti was so friendly as to push a fix to GitHub this morning, so you might want to install spreads from there until we are ready to ship a new version.
spreads: Command-line workflow assistant

Cypris2010
Posts: 11
Joined: 06 Feb 2014, 10:58
Number of books owned: 0
Country: Germany

Re: Spreads on Linux Mint: First Impressions

Post by Cypris2010 » 06 Feb 2014, 16:21

Of witch repository are talking. I installed form https://github.com/jbaiter/spreads just one minute ago and there is the same error.

Cypris2010
Posts: 11
Joined: 06 Feb 2014, 10:58
Number of books owned: 0
Country: Germany

Re: Spreads on Linux Mint: First Impressions

Post by Cypris2010 » 06 Feb 2014, 16:41

Got it working. Thank you for your help.

Cypris2010
Posts: 11
Joined: 06 Feb 2014, 10:58
Number of books owned: 0
Country: Germany

Re: Spreads on Linux Mint: First Impressions

Post by Cypris2010 » 06 Feb 2014, 17:42

Now I can run spread configure. I can select the camera and I can select the plugins. When I hit Enter without a plugin selected I get this.

Code: Select all

Select a plugin (or hit enter to finish):
spreads encountered an error:
Traceback (most recent call last):
  File "/home/fabian/spreads/spread", line 39, in <module>
    cli.main()
  File "/home/fabian/spreads/spreads/cli.py", line 447, in main
    args.subcommand(config)
  File "/home/fabian/spreads/spreads/cli.py", line 159, in configure
    setup_plugin_config(config)
  File "/home/fabian/spreads/spreads/plugin.py", line 370, in setup_plugin_config
    pluginmanager = get_pluginmanager(config)
  File "/home/fabian/spreads/spreads/plugin.py", line 344, in get_pluginmanager
    name_order=True)
  File "/usr/local/lib/python2.7/dist-packages/stevedore/named.py", line 43, in
__init__
    invoke_kwds)
  File "/home/fabian/spreads/spreads/plugin.py", line 79, in _load_plugins
    invoke_kwds,
  File "/usr/local/lib/python2.7/dist-packages/stevedore/named.py", line 95, in
_load_one_plugin
    ep, invoke_on_load, invoke_args, invoke_kwds,
  File "/usr/local/lib/python2.7/dist-packages/stevedore/extension.py", line 146, in _load_one_plugin
    plugin = ep.load()
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2015, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/home/fabian/spreads/spreadsplug/__init__.py", line 31, in <module>
    __import__("spreadsplug.dev." + module[:-3], locals(), globals())
  File "/home/fabian/spreads/spreadsplug/dev/chdkcamera.py", line 12, in <module>
    from jpegtran import JPEGImage
ImportError: No module named jpegtran

Post Reply