Page 1 of 1

Lion

Posted: 20 Jul 2011, 22:59
by ibr4him
Hi,

Will ST work on OS X Lion? Anyone tested yet?

Re: Lion

Posted: 21 Jul 2011, 09:17
by ibr4him
Works! :)

Re: Lion

Posted: 25 Jul 2011, 02:48
by jimboh
Unfortunately, the macports qt4-mac will not build on Lion at this point. The port maintainer is apparently traveling and does not expect to install Lion until August. I am keeping Snow Leopard on the computer that I use to build ST until the bugs are worked out for Lion.

The Qt SDK that can be downloaded directly from Nokia does work on Lion, both the 4.7.3 and 4.8.0 beta versions. Unfortunately, I do not see a relevant Qt .pro file in the ST source code and do not know how to create one, so I have no idea how to use Qt Creator in the Nokia download to build ST on Lion. I'd rather just wait for the macports version to be fixed and stick to the build instructions that I know to work on Snow Leopard.

Re: Lion

Posted: 13 Oct 2011, 02:58
by jimboh
The MacPorts version of the Qt SDK for OS X is still not fixed, so I need to switch to using the Qt SDK downloadable directly from Nokia. Anyone building ST for OS X using the latter? Any special tips on setting things up?

P.S. It was easy. I simply needed to point cmake to the directories containing qmake and the Qt includes:

Code: Select all

All one line:

cmake -DCMAKE_LIBRARY_PATH=/opt/local/lib -DCMAKE_INCLUDE_PATH=/opt/local/include 
-DQT_QMAKE_EXECUTABLE=/Users/Jimbo/QtSDK/Desktop/Qt/4.8.0/gcc/bin/qmake 
-DQT_INCLUDE_DIR=/Users/Jimbo/QtSDK/Desktop/Qt/4.8.0/gcc/include .
It should be possible to set the parameters in the environment.plist file and then enter "cmake ." only.

Re: Lion

Posted: 13 Oct 2011, 10:01
by Misty
Seriously, Macports still hasn't fixed Qt under Lion? That's ridiculous.

Scan Tailor can be built using Homebrew on Lion (and Leopard and Snow Leopard). By default it downloads a Qt SDK binary that is very speedy to install, so you can get Scan Tailor going in about 10 minutes.

Installing Scan Tailor in Homebrew is just a matter of doing

Code: Select all

brew install scantailor
You can also install Scan Tailor Enhanced by doing

Code: Select all

brew install scantailor --enhanced

Re: Lion

Posted: 08 Jan 2012, 00:57
by feliks
Hey all,

getting this error in the terminal when I run scan tailor compiled with homebrew:

"libpng warning: Application built with libpng-1.2.35 but running with 1.5.4"

The app launches and runs, but any "graphics" in the application, i.e. buttons, are blank, including the "play" buttons. Anyone else have these issues? Solution? Or does anyone care to share their compiled binary with me?

Cheers,

-Feliks

Re: Lion

Posted: 18 Jan 2012, 10:32
by dbmoura
I am not an expert in Terminal and its command lines and do not know if I did any unnecessary step here. I already have a installation of Scantailor 0.9.9.2 installed and running in this iMac with Lion, so I am upgrading to the newest version 0.9.11 in this machine.
I succeed in building Scantailor 0.9.11 in Mac OS X Lion in this way.
I have followed <http://sourceforge.net/apps/mediawiki/s ... e_on_Linux> with the following details:
- Downloaded and install Xcode 4.2.1 for Lion in the Mac App Store
- Followed "Migrating a MacPorts install to a new major OS version or CPU architecture" <https://trac.macports.org/wiki/Migration> and used for step 4 the commands of "Automatically reinstall ports (EXPERIMENTAL)"
- Downloaded and install MacPorts for Lion <https://distfiles.macports.org/MacPorts ... 7-Lion.dmg>
- Run the first command line of the item "Prerequisites" in <http://sourceforge.net/apps/mediawiki/s ... e_on_Linux>
- Downloaded and install Qt SDK version 1.1.4 that includes Qt libraries version 4.7.4 - Mac OS X 10.6 or later 64-bit <http://qt.nokia.com/downloads>
- Run the second command line of the item "Prerequisites" in <http://sourceforge.net/apps/mediawiki/s ... e_on_Linux>
- Downloaded and unpack manually Scantailor 0.9.11 and moved it to Applications folder instead one the first command line of "Configuration" in <http://sourceforge.net/apps/mediawiki/s ... e_on_Linux>
- Pointed Terminal to /applications/scantailor-0.9.11 (using CD command)
- Run the second command line of the item "Configuration" in <http://sourceforge.net/apps/mediawiki/s ... e_on_Linux> paying attention of not letting space between the first and the second line of command
- Finally run "Compilation and installation" in <http://sourceforge.net/apps/mediawiki/s ... e_on_Linux>
At the end I have this Scantailor unix executable in the folder of the source files and I successfully launched the new installation and worked on it.

Re: Lion

Posted: 30 Jan 2012, 14:40
by feliks
Can you post your compiled binary? I am having compilation errors.

Thanks!

-Feliks

Re: Lion

Posted: 14 Mar 2012, 20:00
by rob
Misty wrote:Scan Tailor can be built using Homebrew on Lion (and Leopard and Snow Leopard). By default it downloads a Qt SDK binary that is very speedy to install, so you can get Scan Tailor going in about 10 minutes.
brew-rage.png
brew-rage.png (67.51 KiB) Viewed 9582 times
brew-rage 2.png
brew-rage 2.png (216.65 KiB) Viewed 9578 times
Yeah, I'm a fan of rage comix. See my catbox series for example. (Continuation links are in the comments)