Page 1 of 1

Possible bug difficult to diagnose

Posted: 06 Oct 2012, 04:48
by eL_PuSHeR
Hello.

Since a few days ago I am experiencing a weird ST behaviour when creating pages at the last stage (output). If some margins are set at zero, ST will crash with a C++ error or something until margins are corrected. I don't know what's triggering the error and I know it could be very difficult to diagnose.

Any ideas?

Using 0.9.11.1 x64 on Windows 7 x64 with 4GB of RAM.

Re: Possible bug difficult to diagnose

Posted: 06 Oct 2012, 10:22
by eL_PuSHeR
I am doing some more testing. As soon as one of the margins are set to ZERO the crash pops up. At first I thought it had something to do with not applying changes using the arrow on the left panel but today I have seen that's not the case.

This is the screen I get after a crash.

Image

PS - This is for margins:

Top: 3; Down: 0; Left: 3; Right: 3

As soon as I set Down margin to 1 (3,1,3,3), the bug dissappears.

Re: Possible bug difficult to diagnose

Posted: 30 Oct 2012, 05:34
by Tulon
I would take a look, but at this point I've pretty much retired from Scan Tailor development. Haven't touched it for months and never felt like I want to get back to it.

Re: Possible bug difficult to diagnose

Posted: 31 Oct 2012, 04:25
by eL_PuSHeR
No problem. It's just a minor annoyance.

Best regards.

Re: Possible bug difficult to diagnose

Posted: 31 Oct 2012, 12:12
by dtic
@eL_PuSHeR I can't reproduce the problem. And I also run 0.9.11.1 x64 on Windows 7 x64. Does the problem persist even if you reinstall Scan Tailor?

Re: Possible bug difficult to diagnose

Posted: 01 Nov 2012, 05:23
by eL_PuSHeR
Yes I already did that. Same results. As I have said it's not a big deal as I usually use 1-3mm margins.

Re: Possible bug difficult to diagnose

Posted: 14 Nov 2012, 16:09
by eL_PuSHeR
I have found out that margins = 0 work for me when page layout is set to CENTERED. I think it fails when it isn't centered...