Page 1 of 2

won't open in Mint 11

Posted: 21 Sep 2011, 09:17
by Ouaouaron
Everything looks good, it installs and creates and icon on the desktop but when the icon is opened, no program. Help please. :D

Re: won't open in Mint 11

Posted: 21 Sep 2011, 09:24
by steve1066d
Have you tried clicking it a few times? On windows after updating for some reason it doesn't always seem to start. But after a couple of attempts it works fine till I update again.

Re: won't open in Mint 11

Posted: 22 Feb 2012, 23:08
by diogomundi
I can't run it on ubuntu 10.10 too ... any help?
I'm getting this error:
jar resources in jnlp are not signed by the same certificate

Re: won't open in Mint 11

Posted: 25 Feb 2012, 18:22
by abmartin

I can confirm that problem on my linux installs too. That problem was a recent security innovation in Java so that one launch file could only launch programs signed by a single source. The workaround is to create seperate launch files for each signing source. I believe that the creator of the program did this a while back, but I guess the signing of a package changed. (If memory serves, one of them is signed to Steve and the other to unknown)

The solution for us as end users is to install the additional java packages to our sun/oracle java install.
You need the following libraries: ... lease/1.1/ (Image-IO) ... ase/1_1_3/ (Java Advanced Imaging)

Download the appropriate files for your system. (Get the linux jre .bin files for either i586 or 64 bit depending on your system) The installation instructions are also in the directory. I don't know where Ubuntu puts the JRE, but hopefully you (or a search engine) can find that. Hopefully it will all be clear. If java is installed in a system directory (i.e. not your home directoy, so you don't have write privs), you will need to install the command with the friendly neighborhood sudo in front.

One problem I noticed with this process is that the Image-IO file for 64 bit linux is corrupt. It may be for the 32 bit system too. The solution to this is to run the following command in the directory that contains the download:
sed s/+215/-n+215/ jai_imageio-1_1-lib-linux-amd64-jre.bin > jai_imageio-1_1-lib-linux-amd64-jre-fixed.bin (change "amd64" to "i586" if appropriate)

That creates a new, correct file leaving the original intact. When installing imageio, use this new file.

Then, just download BookScanWizard from sourceforge and follow the readme in the directory. I find that I need to launch it with a heap size bigger than the suggested 1024, so I just add 500 to that. (Like most high-level programming languages, we end up with a ton of memory use) You can launch the program via the terminal, alt-f2, or manually enter the launch command to your menu.

I hope this works for you and others. I am running Debian Sid with openbox, which has no Oracle java (thanks to Oracle for changing yet another ) so I installed the JRE manually and used the update-alternatives system to link things together. This is what worked for me. Hopefully it works for you.

The advantage of this approach is that you don't need to be on the net.

I really like the program. Although I know how to do color balance, lens correction, rotate, crop, and correct keystoning with imagemagick, BSW makes it so much simpler and saves a lot of input time!

I'll check this thread to see if you have any questions.

Re: won't open in Mint 11

Posted: 26 Feb 2012, 11:56
by diogomundi
Thank you very much abmartin!!!
I'm still having some problens.

What i did:
cd /usr/lib/jvm/java-6-sun-
chmod 777 /home/diogo/Downloads/jai-1_1_3-lib-linux-i586-jre.bin
chmod 777 /home/diogo/Downloads/jai_imageio-1_1-lib-linux-i586-jre-fixed.bin
sudo /home/diogo/Downloads/jai-1_1_3-lib-linux-i586-jre.bin
sudo /home/diogo/Downloads/jai_imageio-1_1-lib-linux-i586-jre-fixed.bin

When i try to run i got this error:
diogo@diogo-P5K-Premium ~/Downloads/BookScanWizard_1.2/bin $ ./bsw
Unable to access jarfile ./bsw/../BookScanWizard.jar

What i'm doing wrong?

Re: won't open in Mint 11

Posted: 26 Feb 2012, 12:33
by diogomundi
Trying via comand line:

diogo@diogo-P5K-Premium ~/Downloads/BookScanWizard_1.2/bin $ java -Xmx1524 -jar BookScanWizard.jar
Error occurred during initialization of VM
Too small initial heap

Re: won't open in Mint 11

Posted: 26 Feb 2012, 12:46
by diogomundi
abmartin, I just did it!
You are a Genius!

I just had to write a "m" after 1524
java -Xmx1524m -jar BookScanWizard.jar

Thank you so much!!

Re: won't open in Mint 11

Posted: 26 Feb 2012, 12:49
by abmartin
I'm glad that installing the two libraries went well! It took me awhile the first time thanks to the corrupt imageio files.

I just tried to run it from the scripts too. I get the same error as you. I'm not sure why either. (I am not a programmer, and the script seems okay to me)

Try just running the program manually. Forgive me if I get the path wrong. There is a small mistake in the readme: the initial heap doesn't have the definition of megabyte, so it was asking for about 1k of ram. No biggie. I'm not sure why, but on one of my systems, 1024m is just shy of enough. When running through the terminal, it will tell you if the initial heap size is too small. If so, just add to the number until you have enough.

java -Xmx1024m -jar /home/diogo/Downloads/BookScanWizard_1.2/bin/BookScanWizard.jar

If that works for you from the terminal, you can just add that command to your menu.

On my system, since I use the OpenJRE for everything except for BSW, sometimes the default position changes in the alternatives system. That means that sometimes it tries to call the wrong java with that command, leaving me with two options. I can use galternatives to select a default or just expand my command to call the specific java. It's a problem since those two libraries are installed only in the Oracle java install. Hopefully that won't be a problem for you. I think Ubuntu will only really let you have one installed at a time anyway.

Re: won't open in Mint 11

Posted: 26 Feb 2012, 12:55
by abmartin

You figured it out while I was typing! Congrats. It's always better to figure it out for yourself! (for learning, and most importantly: it feels great!)

Hopefully that between your very specific, concise list of commands and my rambling prose, this will be enough to get others on the path to working with BSW! (at least in Debian and Ubuntu!)

Re: won't open in Mint 11

Posted: 26 Feb 2012, 19:53
by diogomundi
I'm very happy now.
I was trying to run bsw on linux for a week at least.
Thank you so much!!!!