Daniel Reetz, the founder of the DIY Book Scanner community, has recently started making videos of prototyping and shop tips. If you are tinkering with a book scanner (or any other project) in your home shop, these tips will come in handy. https://www.youtube.com/channel/UCn0gq8 ... g_8K1nfInQ

Java runtime heap error

Discussion about Steve DeVore's Book Scan Wizard, a power-user package to automate scan processing.
Post Reply
Posts: 17
Joined: 16 Jan 2013, 22:08
E-book readers owned: Kindle, windows tablet
Number of books owned: 20
Country: Australia

Java runtime heap error

Post by CaptOn » 21 Jun 2013, 11:17

Hi guys,
Am finding Book scan wizzard to have alot of promise in terms of increasing the efficiency of my post processing but haven't gotten it to work properly yet.
The problem is i keep getting an error.

java.until.concurrent.ExecutionException:java.lang.OutOfMemoryError: Java Heap space

I have shut down all applications and tried the software on multiple machines with large ammounts of RAM eg 16gb.

Is there something i may be doing wrong that is triggering this?

Any help would be appreciated. Thanks!

Posts: 19
Joined: 16 Jun 2013, 06:13
Number of books owned: 10000
Country: Australia

Re: Java runtime heap error

Post by peterZ » 27 Sep 2013, 03:53

I get exactly the same error. Even for only one image.

Posts: 296
Joined: 27 Nov 2010, 02:26
E-book readers owned: PRS-505
Number of books owned: 1250
Location: Minneapolis, MN

Re: Java runtime heap error

Post by steve1066d » 27 Sep 2013, 09:39

Sorry... I didn't see this thread until today.

What size are your source images? How about your destination images? Are you using the webstart or command line version?

Can you post your configuration script?
Steve Devore
BookScanWizard, a flexible book post-processor.

Posts: 5
Joined: 11 Oct 2013, 12:44
E-book readers owned: iPad
Number of books owned: 2000
Country: US
Location: Norman, OK

Re: Java runtime heap error

Post by chennes » 17 Oct 2013, 23:25

I was having the same problem, but increasing the memory size on the command line resolved the issue for me. I used 4096M instead of the default 1024M.

Post Reply