Page 1 of 1

PDFbeads Error

Posted: 16 Jul 2011, 14:51
by ibr4him
I ran the commands in terminal as Misty explained in another post, but I can't run PDFbeads yet:

Code: Select all

mbpro:~ ibrahim$ pdfbeads /Users/ibrahim/Pictures/LEFT-16_07_2011-100/Karbala/Original pdf.pdf
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require': no such file to load -- RMagick (LoadError)
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
	from /Library/Ruby/Gems/1.8/gems/pdfbeads-1.0.3/lib/pdfbeads.rb:36
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
	from /Library/Ruby/Gems/1.8/gems/pdfbeads-1.0.3/bin/pdfbeads:38
	from /usr/bin/pdfbeads:19:in `load'
	from /usr/bin/pdfbeads:19
mbpro:~ ibrahim$
Many thanks for your help!

Re: PDFbeads Error

Posted: 17 Jul 2011, 01:35
by Misty
PDFBeads doesn't track its dependencies in Rubygems (Alexey, you should do that ;)), so it didn't install the other gems you need for it to work. In addition to PDFBeads itself, you also need rmagick and hpricot. Go ahead and install those the same way you installed PDFBeads itself.

You will need to have Imagemagick installed for it to work. If you don't, I would recommend using a package manager like Homebrew or Macports. With Homebrew, you can install Imagemagick by typing

Code: Select all

brew install imagemagick

Re: PDFbeads Error

Posted: 17 Jul 2011, 02:53
by ibr4him
I think I already have it installed:

Code: Select all

Warning: Formula already installed: imagemagick

Re: PDFbeads Error

Posted: 17 Jul 2011, 12:10
by Misty
That's fine, then. Just go ahead and install rmagick and hpricot using Rubygems, by doing

Code: Select all

sudo gem install rmagick hpricot