Daniel Reetz, the founder of the DIY Book Scanner community, has recently started making videos of prototyping and shop tips. If you are tinkering with a book scanner (or any other project) in your home shop, these tips will come in handy. https://www.youtube.com/channel/UCn0gq8 ... g_8K1nfInQ

pdfbeads problem under Ubuntu Linux 14.04

Discussions, questions, comments, ideas, and your projects having to do with DIY Book Scanner software. This includes the Stereo Data Maker software for the cameras, post-processing software, utilities, OCR packages, and so on.
Post Reply
Posts: 1
Joined: 21 Feb 2016, 12:17
E-book readers owned: iPAD
Number of books owned: 600
Country: Germany

pdfbeads problem under Ubuntu Linux 14.04

Post by Storm » 29 Mar 2016, 12:52

Hello to all Book-Scanners out in the world.

I am pretty new to this forum but I am already addicted about digitally preserving information about things that otherwise will be lost in the future..

I read Nate Crowns web article about book-scanning under Linux and tried to install all necessary tools to build good quality PDF-Documents with lowest possible data sizes.

I am not an in-depth-user of Ubuntu-Linux, so the installation of all necessary software pieces took quite a while due to the numerous dependencies that are not documented and lead to lots of problems if something is missing...

I am finally able to run pdfbeads to bind my ScanTailor output but it only seems to work with mixed mode pages that include text and picture areas...
Text-only pages cause the error-message below and I have no clue what to do in this case:

walter@Ubuntu-ThinkPad-T43p:~/work/out$ pdfbeads Philips_PM6303_OM-001.tif > test.pdf
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': iconv will be deprecated in the future, use String#encode instead.
[DEPRECATION] requiring "RMagick" is deprecated. Use "rmagick" instead
Prepared data for processing Philips_PM6303_OM-001.tif
JBIG2 compression complete. pages:1 symbols:2 log2:1
/var/lib/gems/1.9.1/gems/pdfbeads-1.1.1/lib/pdfbeads/pdfpage.rb:483:in `block in jbig2Encode': undefined method `>' for nil:NilClass (NoMethodError)
from /var/lib/gems/1.9.1/gems/pdfbeads-1.1.1/lib/pdfbeads/pdfpage.rb:461:in `each_index'
from /var/lib/gems/1.9.1/gems/pdfbeads-1.1.1/lib/pdfbeads/pdfpage.rb:461:in `jbig2Encode'
from /var/lib/gems/1.9.1/gems/pdfbeads-1.1.1/bin/pdfbeads:225:in `<top (required)>'
from /usr/local/bin/pdfbeads:23:in `load'
from /usr/local/bin/pdfbeads:23:in `<main>'

In my humble opinion the JBIG2 compression worked, but something is wrong with the ruby script "pdfpage.rb", which is part of the pdfbeads1.1.1-package. I have no clue about ruby and just installed it to be able to run pdfbeads... Maybe I am still missing another dependency but I am not aware what I might have missed to install.

Can anyone in this forum give me a helping hand in order to solve this problem so I can finally use the pdfbeads-script to produce high-quality, low size pdf-manuals of my measurement gear? The file I tried to convert above is attached to this message.

Hoping for some suggestions,


Post Reply