Daniel Reetz, the founder of the DIY Book Scanner community, has recently started making videos of prototyping and shop tips. If you are tinkering with a book scanner (or any other project) in your home shop, these tips will come in handy. https://www.youtube.com/channel/UCn0gq8 ... g_8K1nfInQ

Spreads instalation, configuration and starting

Johannes Baiter's Spreads and SpreadPi are the latest control systems and postprocessors for DIY scanning. http://spreads.readthedocs.org
Post Reply
Posts: 4
Joined: 15 Nov 2014, 05:00
Number of books owned: 98000
Country: Serbia

Spreads instalation, configuration and starting

Post by knjigor » 15 Nov 2014, 17:11

Hi everyone,

I`m having a problems with starting with Spreads. I have instaled it on fresh install of lubuntu 14.04 x64 on MSI wind U160 (dedicated to be book scaning unit), I have used tutorial https://github.com/OliPelz/spreads-ubuntu-trusty to complete instalation (tried about 5 times, all with fresh installs until i managed finaly to start Spreads, web, gui, guiconfig...) and I think that it is working now as it should.

I have two different cameras, Canon A1100IS and Canon A590IS both with chdk 1.3 on sd cards. I will trie to describe situations of them:

This cammera has play/rec swich and I`m having trouble with it. When I start /usr/local/lib/chdkptp/chdkptp_gui to test it, camera connect ok but when i trie to take a picture, it say "not in rec mode" if i clic rec mode in chdkptp noting happends, if i swich buton on camera, computer doesn`t see it any more.

With this one situation is better because it has a play/rec button (not switch), chdkptp recognise it and when i click on rec button i can take a photos and store them directly on computer hdd.

I have configured Spreads exactly as it is written in tutorial, except chdkptp instalation (I installed latest one, everything else is as is). I tested gui, guiconfigure and web and they are working. Problem is when i trie to connect and configure cameras (mainly I was testing A1100IS because i know that i can take a picture with it):

Code: Select all

spread configure output
(.spreads)igor@bsu:~$ spread configure
Please select a device driver from the following list:
  [0]: Keep current (chdkcamera)
  [1]: gphoto2camera
  [2]: chdkcamera
  [3]: dummy
  [4]: None
Select a driver: 2
Selected "chdkcamera" as device driver
Please select your desired plugins from the following list:
  x 1: autorotate
    2: djvubind
  x 3: gui
    4: hidtrigger
    5: intervaltrigger
    6: pdfbeads
  x 7: scantailor
  x 8: tesseract
  x 9: web
Select a plugin (or hit enter to finish): 
The following postprocessing plugins were detected:
 - autorotate
 - scantailor
 - tesseract
Please enter the extensions in the order that they should be invoked, separated by commas or hit enter to keep the current order:

Do you want to configure the target_page of your devices?
(Required for shooting with two devices) [y/N]: y
Setting target page on cameras
Please connect and turn on the device labeled 'odd'
Press any key when ready.
spreads.plugin: Finding devices for driver "CHDKCameraDevice"
spreads encountered an error:
Traceback (most recent call last):
  File "/home/igor/.spreads/local/lib/python2.7/site-packages/spreads/main.py", line 318, in main
  File "/home/igor/.spreads/local/lib/python2.7/site-packages/spreads/main.py", line 308, in run
  File "/home/igor/.spreads/local/lib/python2.7/site-packages/spreads/cli.py", line 232, in configure
    _set_device_target_page(config, target_page)
  File "/home/igor/.spreads/local/lib/python2.7/site-packages/spreads/cli.py", line 177, in _set_device_target_page
    devs = plugin.get_devices(config, force_reload=True)
  File "/home/igor/.spreads/local/lib/python2.7/site-packages/spreads/plugin.py", line 474, in get_devices
    devices = list(driver.yield_devices(config['device']))
  File "/home/igor/.spreads/local/lib/python2.7/site-packages/spreadsplug/dev/chdkcamera.py", line 135, in yield_devices
    yield cls(config, dev)
  File "/home/igor/.spreads/local/lib/python2.7/site-packages/spreadsplug/dev/chdkcamera.py", line 152, in __init__
UnicodeEncodeError: 'ascii' codec can't encode character u'\u0409' in position 0: ordinal not in range(128)
spread -V returns this information:
spreads 0.5git20141115.1250

I get same error with booth cameras.

Can you please help me with this?

Post Reply