Page 1 of 2

RaspberryPi 2

Posted: 12 May 2015, 09:34
by jwnixon
I haven't seen much chatter on here about RPi 2 - has anyone gotten it to work with the current builds of SpreadPi?

I've been working on it unsuccessfully and am just about to drop back to a B+. My SD install runs perfectly on a B+, but when put into a 2 it either gives a kernel error before Spreads launches or a Spreads error when it's launching. (After thoroughly testing the power supply and all other components, I got a manufacturer replacement for my board because it was the only thing left to be at fault. I've started considering going to a B+ when the replacement arrived and it had the same problems as the original.) I'm happy to work with the devel team to get it working, but i don't have the skills to tackle the problem solo.

Re: RaspberryPi 2

Posted: 12 May 2015, 18:46
by steve1066d
I tried using a RaspberryPi 2 as well, without any luck.

I then tried to install Rasbian, then install spreads on top of that... I got close, but in the end I couldn't make that work either.

Then I tried the latest image with a B+, that failed, but then went back to the April 25 image, and that one worked for me.

Re: RaspberryPi 2

Posted: 13 May 2015, 06:20
by adong
I'll get my RPi2 in two weeks, I'll report at that time.

Re: RaspberryPi 2

Posted: 14 May 2015, 09:34
by jwnixon
steve1066d wrote:Then I tried the latest image with a B+, that failed, but then went back to the April 25 image, and that one worked for me.
Thanks, Steve. Glad to know I wasn't missing something. To clarify - did the 25-Apr image work on your RPi 2 or on the B+?

Re: RaspberryPi 2

Posted: 07 Jun 2015, 12:23
by duerig
Johannes did a stealth fix of this bug. I downloaded the latest nightly build. And now it works on a Raspberry Pi 2, or at least boots up and lets me log in. Now to do some more testing.


Re: RaspberryPi 2

Posted: 09 Jun 2015, 14:59
by sunhou
I have a Raspberry Pi 2 and have been trying to get SpreadPi working, with no luck. It always crashes when booting up.

I also tried starting from a stock Raspbian install and getting things working (installing software myself into it), but that has also been very frustrating. I got chdkptp installed, and can connect to my two Cannon PowerShot A2500's and make them shoot photos manually from the command line. No luck getting spreads working yet.

I've tried this over a few weeks, and with a few different nightly builds of SpreadPi over that time. I'm not sure how to proceed -- I have an archivist scanner arriving shortly, and no way to control the cameras right now. Triggering one camera at a time manually from a terminal window on the Pi will be way too slow.

I had a first-gen Raspberry Pi, but that seems to have died on me at some point in the past year -- it will no longer boot at all (the LEDs show it's not even reading the SD card).

Any suggestions for what I should try with my RPi 2?

Re: RaspberryPi 2

Posted: 10 Jun 2015, 10:50
by duerig
I've been finding my Raspberry Pi 2 installation to be unstable as well. I'm not exactly sure why.

To try to fix this (and for other reasons), I have started work on making Spreads images using the standard Raspberry Pi utility Spindle. My thought is that this will produce an image that is as stable as the stock image with extra packages (chdkptp, etc.) and Spreads installed on it as well. This won't be as compact as the current custom image. But it seems like it will be more robust as new Pi versions come out. I hope to have some results later this week.


Re: RaspberryPi 2

Posted: 11 Jun 2015, 17:15
by qv_
Check the volt om the RPI motherbord to see that is 5 volt.

There is a problem with many of the USB cabels.
They are made for data and RPI use them for power so you need one with AWG 28 or so.

I have two Raspberry Pi2 on my desk but I shall not use them for Spreads


Re: RaspberryPi 2

Posted: 11 Jun 2015, 21:24
by duerig
qv_, I have had that difficulty before on a Pi which seemed to be resolved by using a 2 amp power supply. I think this is more of a software issue.

I have successfully created a new set of image build scripts which extend the Spindle system used to make standard Raspbian builds. At present, I have a standard Raspbian image (minus X11 packages) which also includes Spreads and all the packages it requires to run in web mode. When you first boot it, it presents the startup menu that lets you resize the image, set your locale and password, etc. The only user is the standard 'pi' user. In order to run Spreads, you currently have to log in and run it by hand:

Code: Select all

spread web
The advantage currently is that it seems much more stable on a Raspberry Pi 2 than the nightly build from SpreadPi. I have yet to see a kernel crash for any reason. I have successfully created a workflow, taken some scans, and downloaded the resulting zipfile.

I will be doing a more thorough testing and fixing any bugs I come across. I will also work on porting some of the other pieces of the SpreadPi build script, including setting spreads up to run as a service automatically.

If you want to try out the Spreads-ready Raspbian build now, download it from:


Re: RaspberryPi 2

Posted: 12 Jun 2015, 16:30
by sunhou
Jonathon, thanks for your help. I tried your zipfile but still had trouble. At least it would boot up on my RPi2 fine without crashing the kernel. But spread still won't run for me. When I try to run "spread web", I get the errors shown below.

If I run the chdkptp program from your RPi image, I can still talk to my Canon A2500 just fine, so I'm not sure why spread is having trouble. When I run spread, I do briefly see an error message on my camera's screen as well about some lua scripts; maybe there is something else that needs to be added to the camera's SD card? (Though obviously it's close, since chdkptp talks to the camera fine, and lets me shoot without trouble.)

I'm not sure how I can capture the error I saw on the camera screen. When I look under /CHDK/LOGS on the camera's SD card, the directory is empty. Is the message being logged somewhere else?

Here's what I saw when I tried to run spread web:

spreadsplug.web: Starting scanning station server in "scanner" mode
spreads.plugin: Finding devices for driver "CHDKCameraDevice"
[31mspreads encountered an error:[39m
[31mTraceback (most recent call last):
File "/usr/local/lib/python2.7/dist-packages/spreads/", line 321, in main
File "/usr/local/lib/python2.7/dist-packages/spreads/", line 308, in run
File "/usr/local/lib/python2.7/dist-packages/spreadsplug/web/", line 169, in run
File "/usr/local/lib/python2.7/dist-packages/spreadsplug/web/", line 364, in run_server
File "/usr/local/lib/python2.7/dist-packages/spreadsplug/web/", line 327, in display_ip
.format(self._ip_address, self._listening_port))
File "/usr/local/lib/python2.7/dist-packages/spreadsplug/dev/", line 293, in show_textbox
self._device.lua_execute("\n".join(script), do_return=False)
File "/usr/local/lib/python2.7/dist-packages/chdkptp/", line 186, in lua_execute
""" % (lua_code, remote_libs)).values()
File "/usr/local/lib/python2.7/dist-packages/chdkptp/", line 70, in pexecute
return self._parse_rval(self._rt.execute(checked_code))
File "/usr/local/lib/python2.7/dist-packages/chdkptp/", line 36, in _parse_rval
IndexError: tuple index out of range